• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
28 views
error:could not determine the class-path for interface com.android.builder.model.androidproject.
by (5.3k points)  
retagged by

2 Answers

0 votes

Remedy for this issue:

Step1:

* You need to check classpath in build.gradle file. and then replace it with

   classpath 'com.android.tools.build:gradle:2.3.0'

Step2: Then next step is 

2: Go to gradle-wrapper.properties, and replace distributionUrl with following

distributionUrl=http://services.gradle.org/distributions/gradle-3.3-all.zip

Finally rebuild the project it should sort out the issue.

by (1.4k points)  
0 votes

Solution:

Please check gradle plugin version . Open the directory \gradle\m2repository\com\android\tools\build\gradle\, to see all version  installed.

Go to Android Studio, open tab 'Project -> Gradle Scripts', do editing on file build.gradle, update the gradle plugin to latest version .

Conclusion:

The final step is to clean and rebuild the project and run.

by (1.6k points)  
...