• Register
0 votes
1.6k views

Problem :

I have already placed the JSTL JAR file in the WEB-INF/lib directory. But still, the JSP can't resolve the taglib. I get the below error:

Can not find the tag library descriptor for "http://java.sun.com/jsp/jstl/core"

6 5 3
6,930 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution:

If you are using maven then your pom's <dependencies> tag should look like bellow:

<dependencies>
    <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>servlet-api</artifactId>
        <version>2.5</version>
    </dependency>
    <dependency>
        <groupId>javax.servlet.jsp.jstl</groupId>
        <artifactId>javax.servlet.jsp.jstl-api</artifactId>
        <version>1.2.1</version>
    </dependency>
    <dependency>
        <groupId>taglibs</groupId>
        <artifactId>standard</artifactId>
        <version>1.1.2</version>
    </dependency>
</dependencies>

It is working for me.

9 7 4
38,600 points

Related questions

0 votes
1 answer 23 views
1 vote
1 answer 95 views
95 views
Problem : I have decided to learn JSF. I have started writing some code in JSF. If I try to run the application after entering the required URL then I start facing below exception. I am currently using Eclipse and the Tomcat7.0.35. I already added the Jstl.jar and jstl1 ... on above exception but I am not able to fix my error. I am looking for expert who can fix above JSF related exception for me.
asked May 15, 2020 Martin K 6.6k points
0 votes
1 answer 870 views
870 views
Problem : Getting strange error related to constant pool as follows org.apache.tomcat.util.bcel.classfile.classformatexception: invalid byte tag in constant pool: 19
asked Nov 11, 2019 peterlaw 6.9k points
0 votes
1 answer 16 views
16 views
Problem: could not publish to the server. java.lang.indexoutofboundsexception
asked Feb 12 Shovo210 3.1k points
0 votes
1 answer 389 views
389 views
Problem: I have very recently integrated my Tomcat 7 in Eclipse. If I start Tomcat 7 using Eclipse then it shows that my Tomcat is up and running but if I go to http://localhost:8080 in the browser then it gives me following error: HTTP Status 404 - / type Status report ... is already in use by some other service but that did not work either for me. How can I fix above error related to Tomcat 7?
asked Aug 2, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 922 views
922 views
Problem : Currently I am trying to develop the REST API using the Spring Framework I am unable to run my application because of below error. Description: The Tomcat connector configured to listen on port 8080 failed to start. The port may already be in use or the connector may ... this application to listen on another port. My 8080 port on my PC is seems to be busy. How can I fix this issue?
asked Feb 28, 2020 mphil 2.3k points
0 votes
1 answer 4 views
4 views
Problem: the requested resource is not available. tomcat 7 eclipse.
asked 5 days ago Dan phillip 1.9k points
0 votes
1 answer 8 views
8 views
Problem: warn unable to instantiate org fusesource jansi windowsansioutputstream
asked Feb 12 Dan phillip 1.9k points