• Register
0 votes
71 views

Problem :

I am getting bellow error while I'm trying to setup an Android dev environment on Mac

error:buildtools 24.0.2 requires java 1.8 or above. current jdk version is 1.7.

6 5 3
6,930 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution:

Please make sure your JDK Version through Project Structure is as shown in bellow screen shot

enter image description here

Now you must add below code in your gradle section

    compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_8
    targetCompatibility JavaVersion.VERSION_1_8
  }
Its working fine for me.
9 7 4
38,600 points

Related questions

0 votes
1 answer 19 views
19 views
I am finding the script for getting current time in 24 hour format in android.
asked Oct 4, 2020 Daniel Anderson 4k points
1 vote
1 answer 3 views
3 views
Problem: Need to know how to fix this problem? No idea annotations attached to the jdk 1.8 android studio.
asked Mar 24 PkGuy 13.1k points
0 votes
1 answer 17 views
17 views
I have uninstalled all the java version instances and reinstalled the latest one, Still, the problem persists.
asked Feb 11 TeamScript 13.5k points
0 votes
1 answer 221 views
221 views
Problem : I am facing the below error "Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled." Above error occurs while using a latest Gradle Plugin & a latest Android SDK.
asked Feb 3, 2020 jwilliam 3.9k points
0 votes
1 answer 11 views
11 views
Problem: could not find com.android.tools.build:aapt2:3.2.1-4818971.
asked Feb 16 charles mathews 5.5k points
0 votes
1 answer 119 views
119 views
Problem : I have updated my Android Studio to 3.0 but now facing the lot of issues.. So now stopped on the point with below issue: Could not resolve all files for configuration ':applib:_lintClassPath'. > Could not find com.android.tools.lint:lint-gradle:26.1.0-alpha01. ... project :applib I am currently using latest gradle version as: "gradle-4.2.1-all.zip". Does anyone know what my issue can be?
asked Dec 17, 2019 alecxe 7.5k points
0 votes
1 answer 19 views
19 views
I fixed the problem by uninstalling jdk 10 and installing jdk8.
asked Feb 11 TeamScript 13.5k points
0 votes
1 answer 94 views
94 views
Problem: this application requires a java runtime environment 1.8.0
asked Feb 19 Dan phillip 4.8k points
0 votes
1 answer 63 views
63 views
Problem : Now a days I am learning Android Programming. I am facing below error message while trying to implement the logout functionality for the Google Sign-In for the Android: “Caused by: java.lang.IllegalStateException: GoogleApiClient is not ... .getInstance().getClient(); Auth.GoogleSignInApi.signOut(myGoogleApiClient); } I am struggling to find solution on it since yesterday.
asked Feb 27, 2020 mphil 2.3k points
0 votes
1 answer 31 views
31 views
I receive this error message when I try to open Gephi. I have the latest version of Java 9 installed and have Windows 10. I have tried uninstalling gephi and reinstalling it and still get the same message.
asked Jan 19 TeamScript 13.5k points