• Register
search
Log In
0 votes
162 views

Problem :

I am getting bellow error while I'm trying to use visual studio code for Java.

this version of the java runtime only recognizes class file versions up to 52.0

6.9k points

1 Answer

0 votes

Solution:

You must be compiling with java 9, but still using JDK 8.0

You need to Install java 9 and also change your OS environment settings to point to the new JDK. 

This is working fine for me.

Further Readings:

https://github.com/yPedx/SpigotBoard/issues/16

36.1k points
edited by

Related questions

1 vote
1 answer 8 views
8 views
Problem: I Created a Loan.java and compile it with JDK 1.6 and Run Loan.class with JRE 1.5. C:\Program Files\Java\jre1.5.0_06\bin>java -version java version "1.5.0_06" The following thing gives an error message: C:\Program Files\Java ... Source)         at java.net.URLClassLoader.defineClass(Unknown Source)         at java.net.URLClassLoader.access$100(Unknown Source) what should i do next ..
asked Mar 27 LizzyM 5.7k points
2 votes
1 answer 16 views
16 views
Problem: I Create Loan.java and compile it with JDK 1.6 and Run Loan.class with JRE 1.5. C:\Program Files\Java\jre1.5.0_06\bin>java -version java version "1.5.0_06" its shows error like bellow C:\Program Files\Java\jre1.5.0_06\bin ... Unknown Source)         at java.net.URLClassLoader.defineClass(Unknown Source)         at java.net.URLClassLoader.access$100(Unknown Source) what should i do next ..
asked Mar 24 LizzyM 5.7k points
0 votes
1 answer 71 views
71 views
Problem : I am getting this error when I include an opensource library that I had to compile from source. java lang unsupportedclassversionerror bad version number in class file
asked Oct 23, 2019 peterlaw 6.9k points
0 votes
1 answer 97 views
97 views
Problem : When I run my Java code in Eclipse, I get the bellow error message there is insufficient memory for the java runtime environment to continue
asked Oct 23, 2019 peterlaw 6.9k points
1 vote
2 answers 31 views
31 views
Problem: Dear all, Right now I’ve imported a maven project into my eclipse IDE and I changed my java path library to work on java 1.7 Suddenly, eclipse started showing an error but I’ve got no errors in my files there. The error is “java compiler level ... Project Problem (Java Version Mismatch) Please tell me how to resolve this error (I want to have my JRE version as 1.7 only).
asked Mar 22 Gavin 15k points