• Register
0 votes
80 views

Problem :

I am getting this error when I include an opensource library that I had to compile from source.
java lang unsupportedclassversionerror bad version number in class file
6 5 3
6,930 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

The reason behind you are getting this message is one of your projects is compiling 1.6 classes. It wont matter if you only have a 1.5 JRE on the system, because Eclipse has its own compiler and only needs a 1.5 JRE to compile 1.6 classes.

Follow bellow steps to resolve the issue:

Check the Project Properties>Java Compiler section

enter image description here

Further Readings:

https://www.eclipse.org/forums/index.php/t/1067175/

9 7 4
38,600 points

Related questions

2 votes
1 answer 23 views
23 views
Problem: I Create Loan.java and compile it with JDK 1.6 and Run Loan.class with JRE 1.5. C:\Program Files\Java\jre1.5.0_06\bin>java -version java version "1.5.0_06" its shows error like bellow C:\Program Files\Java\jre1.5.0_06\bin ... Unknown Source)         at java.net.URLClassLoader.defineClass(Unknown Source)         at java.net.URLClassLoader.access$100(Unknown Source) what should i do next ..
asked Mar 24, 2020 LizzyM 6.1k points
0 votes
1 answer 22 views
22 views
Therefore, I have to conclude something else, internal to a class itself, is throwing the exception?? Is that even possible?
asked Jan 4 TeamScript 13.5k points
1 vote
1 answer 20 views
20 views
Problem: I Created a Loan.java and compile it with JDK 1.6 and Run Loan.class with JRE 1.5. C:\Program Files\Java\jre1.5.0_06\bin>java -version java version "1.5.0_06" The following thing gives an error message: C:\Program Files\Java ... Source)         at java.net.URLClassLoader.defineClass(Unknown Source)         at java.net.URLClassLoader.access$100(Unknown Source) what should i do next ..
asked Mar 27, 2020 LizzyM 6.1k points
0 votes
1 answer 3 views
3 views
Problem: How can I downgrade Java if it was not installed before?
asked 3 days ago Humaira ahmed 15.2k points
1 vote
1 answer 4 views
4 views
Problem: I am unable to find out the solution, Please solve it : peer reports incompatible or unsupported protocol version.
asked Apr 4 MUHAMMAD MUNEEB 83k points
0 votes
1 answer 5 views
5 views
Problem: Please help me fix this dilemma: to build android project, which version of gradle is required
asked Apr 1 rakib1 51.5k points
1 vote
1 answer 4 views
4 views
Problem: How to fix this error : version `glibc_2.14' not found
asked Mar 13 MUHAMMAD MUNEEB 83k points
0 votes
1 answer 14 views
14 views
can anyone help me?
asked Jan 19 TeamScript 13.5k points
0 votes
1 answer 273 views
273 views
Problem: hello fellow developers, I am working on a Firebase messaging application on my Xcode 11, and the Swift version is 5. I really need your help as I am stuck on an issue and this is giving me a headache. Kindly help me to resolve this issue.
asked Oct 12, 2020 SapperIt 1.2k points
0 votes
1 answer 2 views
2 views
Problem: I'm having trouble finding a solution; could you please assist me>not targeting the latest versions of android
asked 3 days ago ashik 12.9k points