• Register
0 votes
117 views

Problem :

I am getting bellow error when running a JUnit test using IntelliJ IDEA

error java javactask source release 1.7 requires target release 1.7

6 5 3
6,930 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

There are two ways to resolve this issue:

  1. Set settings (File -> Settings -> Build, Execution, Deployment -> Java Compiler): enter image description here
  2. Add bellow build section to your pom.xml: enter image description here

Further Readings:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/206206319-Upgraded-to-12-1-4-and-now-java-javacTask-source-release-1-7-requires-target-release-1-7-

9 7 4
38,600 points

Related questions

0 votes
2 answers 526 views
526 views
Problem : Using IntelliJ IDE can not compile any projects getting bellow error error:java: javactask: source release 8 requires target release 1.8
asked Nov 1, 2019 peterlaw 6.9k points
0 votes
2 answers 137 views
137 views
Problem : Using IntelliJ IDE unable to compile any projects getting bellow error error:java: javactask: source release 1.8 requires target release 1.8
asked Oct 31, 2019 peterlaw 6.9k points
0 votes
1 answer 8 views
8 views
Does anybody have any ideas?
asked Dec 19, 2020 TeamScript 9.2k points
0 votes
1 answer 11 views
11 views
Solve this.
asked Dec 27, 2020 TeamScript 9.2k points
0 votes
1 answer 25 views
25 views
Problem: Hello Kodlogs, I'm trying to run my JSQL parser class, but I'm getting Error: java: invalid source release 1.9. I am all trying to understand and find the problem to fix the error. Could you please help me out to fix the error on my ... the solution. I found the forum helpfull and friendly that makes me posting and seeking help here. I look forward reading your comments. Thanks.
asked Jun 21, 2020 adamSw 11.3k points
0 votes
1 answer 11 views
11 views
How can I correct this?
asked Dec 28, 2020 TeamScript 9.2k points
0 votes
1 answer 15 views
15 views
Solve this error.
asked Dec 26, 2020 TeamScript 9.2k points
0 votes
1 answer 61 views
61 views
Problem : I am getting bellow error while I'm trying to setup an Android dev environment on Mac error:buildtools 24.0.2 requires java 1.8 or above. current jdk version is 1.7.
asked Oct 19, 2019 peterlaw 6.9k points
0 votes
1 answer 888 views
888 views
Problem: I am very new to Cucumber. Recently I was reworking my project in the Intellij into my modules and suddenly I came across below error: "C:\Program Files\Java\jdk1.8.0_181\bin\java.exe" "-Dorg.jetbrains.run.directory=C:\Users\Raphael\Documents\1_Code Stuff ... guru-pet-clinic" Error: Could not find or load main class cucumber.cli.Main Can some Cucumber expert help me in fixing above error?
asked Jul 27, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 159 views
159 views
Problem : I'm trying to run Java Applet and every time I try to run program, I got this this error. error: java.lang.illegalstateexception: failed to create a child event loop
asked Oct 23, 2019 peterlaw 6.9k points