• Register
search
Log In
0 votes
199 views

Problem :

Using IntelliJ IDE can not compile any projects getting bellow error
error:java: javactask: source release 8 requires target release 1.8
6.9k points

2 Answers

0 votes

Solution :

I fixed the issue just by changing target compile version to 1.8.

Please goto bellow path to change the target compile version to 1.8

File >> Settings >> Build, Execution, Deployment >> Compiler >> Java Compiler

Further Readings:

https://github.com/mccorby/FederatedServer/issues/2

36.1k points
0 votes

Solution:

  1. File > Settings > Build, Execution, Deployment > Compiler > Java Compiler

  2. Alter Target bytecode version to 1.8 of the module that you are performing for.

In case you are employing Maven

Include the compiler plugin to pom.xml under the top-level project node:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

Note: In case you don't mind reimporting your project, then the just conceive you truly require to do is alter the pom and reimport the project, then IntelliJ will collect the right settings and you don't have to manually alter them.

This seems like the kind of error that Maven originates at the time you don't have the compiler plugin configured properly. Here's an instance of a Java 8 compiler config.

<project xmlns="http://maven.apache.org/POM/4.0.0"
     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
     xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

<!-- ... -->

    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.5.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
            </plugin>
        </plugins>
    </build>

<!-- ... -->

</project>

The quickest method I found:

  • First, Press:CTRL + SHIFT + A (For Mac ⌘ + SHIFT + A)

  • Then, type: java compiler

  • Lastly, press: ENTER

In the Settings window, fix the Target bytecode to 1.8

Like stated on the wiki page of the Apache Maven Compiler Plugin you can only fix the 2 properties employed by the plugin.

<project>
  [...]
  <properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
  </properties>
  [...]
</project>

I solved this by going to Project Structure -> Modules, trace the module in question, click on Dependencies tab, alter Module SDK to Project SDK.

12.8k points
edited by

Related questions

0 votes
2 answers 70 views
70 views
Problem : Using IntelliJ IDE unable to compile any projects getting bellow error error:java: javactask: source release 1.8 requires target release 1.8
asked Oct 31, 2019 peterlaw 6.9k points
0 votes
1 answer 64 views
64 views
Problem : I am getting bellow error when running a JUnit test using IntelliJ IDEA error java javactask source release 1.7 requires target release 1.7
asked Nov 1, 2019 peterlaw 6.9k points
0 votes
1 answer 8 views
8 views
Problem: Hello Kodlogs, I'm trying to run my JSQL parser class, but I'm getting Error: java: invalid source release 1.9. I am all trying to understand and find the problem to fix the error. Could you please help me out to fix the error on my ... the solution. I found the forum helpfull and friendly that makes me posting and seeking help here. I look forward reading your comments. Thanks.
asked Jun 21 adamSw 9.8k points
0 votes
1 answer 43 views
43 views
Problem : I am getting bellow error while I'm trying to setup an Android dev environment on Mac error:buildtools 24.0.2 requires java 1.8 or above. current jdk version is 1.7.
asked Oct 19, 2019 peterlaw 6.9k points
0 votes
2 answers 138 views
138 views
Problem : I am getting the bellow error: Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required.
asked Oct 31, 2019 peterlaw 6.9k points