• Register
0 votes
980 views

Problem :

Getting bellow error related to curses in python code

curses is not supported on this machine (please install/reinstall curses for an optimal experience)

6 5 3
6,930 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I had encountered the similar problem in the past.
Please follow bellow steps to resolve your issue.
  • hdf5 not supported
    • You can reinstall hdf5 to solute
  • Scipy not supported!
    • First ,you should install numy+mkl ,after setup successd try import tflearn .
    • if you get error again,you can reinstall Scipy

Please refer bellow screen shot:

enter image description here

Further Readings:

9 7 4
38,600 points

Related questions

0 votes
2 answers 348 views
348 views
Problem : Currently I have installed Python version 3.5 and 3.6 and anaconda on my box. The following error comes up while trying to install tensorflow below are the steps https://www.tensorflow.org/install/install_windows using the anaconda (tensorflow) C:> pip install --ignore- ... . As I am very much new to Python, I am unable to resolve this problem. I am using the Windows 10 with 64bit.
asked Dec 11, 2019 alecxe 7.5k points
0 votes
1 answer 24 views
24 views
Problem: I have the following code (in PyCharm (MacOS)): import pandas as pd fiddy_states = pd.read_html('https://simple.wikipedia.org/wiki/List_of_U.S._states') print(fiddy_states)
asked Feb 20 Mashhoodch 9.6k points
0 votes
1 answer 75 views
75 views
Problem : I wanted to install a .NET 472 developer pack on my Windows 10 machine from long time, and when I tried to install it got below error. I was able to install .NET 472 developer pack on my other Win10 machines, and also on my Win7 machine. So I don’t ... OSInstallationType = "Client")) OR (VersionNT = v6.3) OR (VersionNT = v10.0 AND OSBuildNumber >= 14393) OR (VersionNT > v10.0))
asked Jan 27, 2020 jwilliam 3.9k points
0 votes
1 answer 16 views
1 vote
2 answers 325 views
325 views
Problem : I am trying to use the reCaptcha but I am facing below error “Localhost is not in the list of supported domains for this site key.” I want to develop my website using the PHP and also I want to make the human verification in one of my sessions. So ... running my system locally and when my system is ready I want to put it on in the certain domain. How can I fix above error?
asked Mar 31, 2020 morrisBson 3.2k points
0 votes
1 answer 19 views
19 views
Problem: I wrote the following code which extracts the info. of a file and orders it alphabetically based on its second column objects: import csv import operator import sys def re_sort(in_file='books.csv', out_file='books_sort.csv'): data = csv.reader(open('books. ... function. Do you guys see reasons why this may be happening. The following if a structured version of the contents in the file
asked Feb 21 Mashhoodch 9.6k points
1 vote
1 answer 388 views
388 views
Problem: I was trying open some file using python and I wrote the code: import numpy as np doland = open('talks.txt', encoding='utf8').read() holland = open('h-talks.txt', encoding='utf8').read() print(doland) But the code always hrows a error ... ^ TypeError: 'encoding' is an invalid keyword argument for this function Whats problem in my code please help me to solve this. Thanks in advance.
asked Apr 21, 2020 samhaz 5k points
0 votes
2 answers 560 views
560 views
Problem: I am new at java programming and I used a method: java.io.File>list( which is used to obatain the list of files and and directories in the specified directory defined by its path name. This list of files are stored in a string array. If the length of this string ... .out.println("The directory " + directory.getPath() + " is empty"); } } But it does not seems to work can anyone help?
asked Mar 21, 2020 LizzyM 6.1k points
0 votes
2 answers 119 views
119 views
i already installed pyaudio but the problem is when i work with the microphone functions import speech_recognition as sr r = sr.Recognizer() mic = sr.Microphone() the problem is in the third line mic = sr.Microphone() the terminal will give me this message Please build ... distribution found for PortAudio so can any one help , it is like i have the pyaudio but the PortAudio is not there !!
asked Oct 24, 2020 psandprop 2.4k points