Programmers learn & share
0 votes

Problem :

Facing following error on Arch Linux with node-sass here I am using it with gulp-sass.

node sass does not yet support your current environment: os x 64-bit with unsupported runtime

by (6.9k points)  
edited by | 163 views

2 Answers

0 votes

Solution :

I managed to solve this issue using the following command.

npm audit fixWorked for me !!

npm audit fix

I tried following command - Didn't worked for me

sudo npm rebuild node-sass

Then I tried following commands - Didn't worked for me

npm uninstall --save-dev node-sass


npm install --save-dev node-sass
So use npm audit fix to ressolve the issue.
by (36.1k points)  
0 votes


1. Open your package.json file and in “devDependencies” section, change “gulp-sass” version to “^3.0.1” and save the file.

2. Run npm install

npm rebuild node-sass

run npm rebuild node-sass


run sudo npm rebuild node-sass

in some cases you need to uninstall and install node-sass library. Try:

npm uninstall --save-dev node-sass


npm install --save-dev node-sass

node-sass v4.11.0 doesn't work with Node 12.

I faced this problem when I upgraded node to v12.

Rebuilding node-sass as suggested by the other answers didn't work as well.

Upgrading node-sass to v4.12.0 fixed it for me.

npm install node-sass@4.12.0

npm audit fix - Worked for me

npm audit fix

Go the path where node-sass is present and run this command

npm rebuild node-sass --force

go with latest node-saas you should be fine:

"node-sass": "^4.11.0",


ago by (7.6k points)  
2,204 questions
2,598 answers
241 users