• Register
0 votes
52 views

Problem :

I am trying to install theano with the help of following command:

conda install theano

on my Ubuntu 16.04. But facing following import problems.

import theano Traceback (most recent call last):

File"/home/milenko/miniconda3/lib/python3.6/configparser.py", line 2138, in _unify_values

sectiondict = self._sections[section]

KeyError: 'blas'

File "/home/milenko/miniconda3/lib/python3.6/site-packages/theano/configdefaults.py", line 3152, in check_mkl_openmp

raise RuntimeError('To use MKL 2018 with Theano you MUST set "MKL_THREADING_LAYER=GNU" in your environement.')

RuntimeError: To use MKL 2018 with Theano you MUST set "MKL_THREADING_LAYER=GNU" in your environement.

How to resolve this issue? Any clues?

6 5 3
7,540 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I had also faced the similar error in the recent past on my Ubuntu-GNOME 16.04.

To resolve this error , I had done lot of research on it and finally I found the solution on it as follows:

 I simply added the export statement in my .zshrc as follows:

export MKL_THREADING_LAYER=GNU

And after that I executed the following command to compile the configuration file as follows :

$ source ~/.zshrc

After this command , I could import theano without any issues.

OR

 You can solved your problem as follows:

I found that MKL 2018 has some very serious problems

So I executed the following commands.

conda uninstall mkl=2018
conda install mkl=2017

And it resolved my problems.

9 7 4
38,600 points

Related questions

0 votes
1 answer 2K views
2K views
Problem : I am getting following pydot error importerror: failed to import pydot. you must install pydot and graphviz for `pydotprint` to work.
asked Nov 8, 2019 peterlaw 6.9k points
0 votes
1 answer 120 views
120 views
Problem : I am in a process of upgrading my codeigniter from the 1.7.2 to 2.0.1. Everything seems to have gone as expected except I get below error: “In order to use the Session class you are required to set an encryption key in your config file.” ... .0.1 that has caused above error? What change should I do to fix the above error. Will making the said change break anything for me?
asked Feb 4, 2020 jwilliam 3.9k points
0 votes
1 answer 65 views
0 votes
1 answer 39 views
39 views
Problem: Hello kodlogs, How can we use for loop in the python to iterate over the sequence of element I have a confusion over the range() function and the datatype like list, tuple and string. Like how can we access the elements in the list
asked Jun 9, 2020 Gavin 15.3k points
0 votes
1 answer 33 views
33 views
Problem: Hello Kodlogs, I tried pushing my app and I got an error message of this nature; you must use bundler 2 or greater with this lockfile. What can I do to correct this?
asked Nov 2, 2020 Festus James 360 points
0 votes
1 answer 173 views
173 views
Problem : I have my Spark app which runs without any problem in the local mode, but have some problems when trying to submit to my Spark cluster. The error message is as below: 20/01/05 15:42:06 WARN scheduler.TaskSetManager: Lost task 2.0 in stage 0.0 (TID 2, ... but I have already provided the "--master" parameter to my spark-submit. Anybody who can fix above problem? My Spark version : 1.6.1
asked Jan 6, 2020 alecxe 7.5k points
0 votes
1 answer 347 views
347 views
Problem: I am trying to write the application and some part of its functionality is to generate the LaTeX CVs so I am finding myself in the difficult situation where I have the strings as shown below: \begin{document} \title{Papers by AUTHOR} \author{} \date{} \ ... working for me and also the dictionary is not working with the %(email)s syntax. Can someone help me in fixing the LaTeX issue?
asked Jul 13, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 5.1K views
5.1K views
Problem : I am using Pandas 0.20.3 in my python 3.X. I for the first time and want to add one column in a pandas data frame from the other pandas data frame. My both the data frame contains 51 rows. So I tried following code: class_df['phone']=group['phone ... when I type(group['phone']) it returns the pandas.core.series.Series Can anyone suggest me what changes I need to do to remove above error?
asked Nov 27, 2019 alecxe 7.5k points
0 votes
1 answer 12 views