• Register
0 votes
478 views

Problem :

I want to learn the Machine Learning but I am unabe to resolve below error.

My Specs :

·         Mac High Sierra 10.13.2

·         Python3.4.5

·         Numpy1.13.3

 

Used below Command:

$ python3 -c "import jupyter, matplotlib, numpy, pandas, scipy, sklearn"

 

I am facing below Error:

RuntimeError: module compiled against API version 0xc but this version of numpy is 0xb

Traceback (most recent call last):

File "/Users/uekyo/ml/env/lib/python3.4/site-packages/pandas/__init__.py", line 36, in <module>

from pandas._libs import (hashtable as _hashtable,

File "/Users/uekyo/ml/env/lib/python3.4/site-packages/pandas/_libs/__init__.py", line 8, in <module>

from .tslib import iNaT, NaT, Timestamp, Timedelta, OutOfBoundsDatetime

File "pandas/_libs/tslib.pyx", line 2, in init pandas._libs.tslib

ImportError: numpy.core.multiarray failed to import

During handling of the above exception, another exception occurred:

Traceback (most recent call last):

File "<string>", line 2, in <module>

File "/Users/uekyo/ml/env/lib/python3.4/site-packages/pandas/__init__.py", line 40, in <module>

"the C extensions first.".format(module))

ImportError: C extension: numpy.core.multiarray failed to import not built. If you want to import pandas from the source directory, you may need to run 'python setup.py build_ext --inplace --force' to build the C extensions first.

6 5 3
7,540 points

1 Answer

0 votes

Solution :

The reson behind your error is most likely due to the version of numpy too low; below code solved my problem:

pip3 install "numpy == 1.15.0" --user 

conda install couldnt solve it because currently it only have the numpy version 1.13.1, but is may be due to the my mirror site choosen is not the latest.

9 7 4
38,600 points

Related questions

0 votes
1 answer 244 views
244 views
Problem : I am trying to execute below commands. import numpy as np import cv But I am getting following error on my console: >>> runfile('/Users/isaiahnields/.spyder2/temp.py', wdir='/Users/isaiahnields/.spyder2') RuntimeError: module compiled against API version a but this ... it is not working. I had added cv.py to the python2.7 folder in Spyder-Py2 is there anything else I need to add?
asked Dec 4, 2019 alecxe 7.5k points
0 votes
1 answer 73 views
73 views
Problem : I have recently installed the opencv 2.4.8 . I am also using python 2.7. I have tried to add my opencv lib to the python according to the tutorial however when I wanted to import my opencv I encountered below error: import cv2 RuntimeError: module compiled ... above error. How can I fix above problem? I researched on still I am unable to find the solutions. Currently I use Windows 7.
asked Dec 21, 2019 alecxe 7.5k points
0 votes
1 answer 19 views