• Register
0 votes
2.2k views

Problem :

I want to view my php files locally on my mac.

I am trying to run Yosemite on my mac.

I have the MAMP installed on my mac. When I press start my MySQL server starts as usual but my Apache doesn't start at all. An error message is shown as below :

 'Error. Apache couldn't be started. Please check your MAMP installation'

I have tried changing 'envvars' to '_envvars' but nothing really works for me.

I also tried reinstalling the OSX and that worked but until I shut down my mac the problem reoccurs.

Can anyone help with the solution on above error?

6 5 3
7,540 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

If you are trying to start your server from the terminal then it is likely that it will tell you what is wrong with it e.g.

$ sudo /Applications/MAMP/bin/startApache.sh

Password:

‘Error :(49)Address already in use: make_sock: could not bind to address [::]:8888 (49)Address already in use: make_sock: could not bind to address 0.0.0.0:8888 no listening sockets available, shutting down Unable to open logs’

In the above explained case, I was trying to run the Blockstack browser out of 8888, so just changing the MAMP to 8887 allowed it to start.

Hope this will help you in resolving your issue.

9 7 4
38,600 points

Related questions

1 vote
1 answer 6 views
6 views
Problem: I have MAMP installed on my PC BUT AFTER STARTING My SQL server I get this error. Mamp apache couldn't be started. please check your mamp installation and configuration.
asked Apr 18 PkGuy 23.5k points
0 votes
1 answer 1.6K views
1.6K views
Problem : When attempting to start the servers, Apache fails to start, and MAMP claims that my port ([::]:8888) is already in the use. I have tried virtually every way I know of determining what the process is using that port (as well as many of other solutions ... what(if anything) is really using my port, or somehow convince the MAMP that my port is not actually in use. Any suggestions on this?
asked Jan 17, 2020 jwilliam 3.9k points
0 votes
1 answer 8 views
8 views
Problem: can someone please help for this problem? the mcrypt extension is missing please check your php configuration
asked Apr 17 Rohit kr 17.5k points
0 votes
1 answer 3 views
3 views
Problem: Apache: AuthType not set! 500 Error.The question remains, how do I solve this 500 error?
asked Apr 14 Humaira ahmed 50.7k points
0 votes
1 answer 10 views
10 views
Problem: It's been a while since I used the Apache httpd web server. I'm firing up a local server for a project and when I try to request localhost/index.html, I get a 500 error and I see this in the error log: Configuration error: couldn't perform authentication. authtype not set!: PLease help?
asked Apr 8 Sana8989 8.9k points
0 votes
1 answer 6 views
6 views
Problem: Jnlp suddenly broken with java web start,how can I resolve this?
asked Apr 14 sumaiya simi 43.9k points
0 votes
1 answer 10 views
10 views
Problem: I am unable to understand this problem .. Please suggest me a better solution to solve it ..pdoexception: sqlstate[hy000] [2002]
asked Apr 20 Ifra 37.2k points
0 votes
1 answer 28 views
28 views
Problem: How do I solve this > Error: apache shutdown unexpectedly. this may be due to a blocked port, missing dependencies,
asked Apr 24 ummeshani 10.8k points
1 vote
1 answer 11 views
11 views
Probem: I have XAMPP installed and when start to run my apache server I get this error. Error apache shutdown unexpectedly. this may be due to a blocked port missing dependencies xampp.
asked Apr 22 PkGuy 23.5k points
0 votes
1 answer 20 views
20 views
Problem: I having the problem while compiling the my project in eclipse. It was shoving the error The import org.apache.commons cannot be resolved. Please anyone tell me what does this error tells and how to solve it.
asked Apr 14 Atik03 26.5k points