• Register
1 vote
1.1k views

Problem :

I want to run the newly compiled binary on some of the very oldish 32bits RedHat distribution.
This binary is compiled C (not C++) on the CentOS 32bits VM running the libc v2.12.

RedHat complains about the libc version as below:

“Error while loading shared libraries: requires glibc 2.5 or later dynamic linker”

Since the program is very simplistic, that’s why it is most likely not using anything new from the libc.

Is there any way to reduce the libc version requirement?

6 5 3
7,540 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I already had the same problem in the recent past while I was trying to compile the little tool which I wrote for the old machine for which I had not any compiler. I compiled it on the up to date machine, and that binary required at least GLIBC 2.14 in order to run it.

By making the dump of a binary with xxd, I found below lines :

....
5f64 736f 5f68 616e 646c 6500 6d65 6d63  _dso_handle.memc
7079 4040 474c 4942 435f 322e 3134 005f  py@@GLIBC_2.14._
....

So I simply replaced my memcpy calls in the code by the call to a home-made memcpy, and a dependency with a glibc 2.14 magically disappeared.

I hope the above solution helps you in resolving your issue.

9 7 4
38,600 points

Related questions

0 votes
1 answer 3 views
3 views
Problem : error adding symbols: dso missing from command line
asked 1 day ago Shovo210 2.3k points
1 vote
2 answers 210 views
210 views
Problem : I am trying to learn the GCC. If I execute the below command then I always face the following error. make -j4 Error received: checking for suffix of object files... configure: error: in `/mnt/LFS/source/gcc-4.6.2/x86_64-lfs-linux-gnu/libgcc': configure: ... See `config.log' for more details. make[1]: *** [configure-target-libgcc] Error 1 Can somebody guide me in fixing above error?
asked Mar 27, 2020 morrisBson 3.2k points
2 votes
1 answer 50 views
50 views
Problem: I started learning C++ programming recently and trying to write my very first program in C++. Here is my sample code #include <iostream> #include <Stdio.h> using namespace std; int main(){ cout << "I am a C++ program" << endl; return 0; } As ... last thirty minutes and failed to gather the information about it. Could you, please save my day? I must recognize your kind help. Thanks, guys.
asked Apr 16, 2020 Gavin 15.3k points
0 votes
1 answer 144 views
144 views
Problem : I am facing following MinGW issue: 'gcc' is not recognized as an internal or external command, operable program or batch file.
asked Nov 18, 2019 peterlaw 6.9k points
0 votes
1 answer 34 views
34 views
I am getting this error suddenly while running my app through iPhone simulator: clang: error: linker command failed with exit code 1 (-v option to see invocation):  ld: duplicate the symbol _OBJC_CLASS _ $ _ Algebra5FirstViewController in ... ... .build/Debug-iphonesimulator/PSLE Algebra5.construire / Objets-normal / i386 / PSLE_Algebra5FirstViewController.o for the i386 architecture What is that?
asked Nov 17, 2020 sasha 8.4k points
0 votes
2 answers 110 views
110 views
Problem : While trying to compile my C program I encountered following error agreeing to the xcode/ios license requires admin privileges, please re-run as root via sudo.
asked Nov 16, 2019 peterlaw 6.9k points
1 vote
1 answer 1.2K views
1.2K views
Problem: I am very new to Programming. I want to compile my recently written program it is called myes3 but when I try to write from the terminal: gcc myes3.c -o myes3 I always face below error message: /usr/lib/gcc/i686-linux-gnu/4.4.5/../../. ... collect2: ld returned 1 exit status I have very elementary knowledge of programming so unable to fix above error. Please help me in fixing above error.
asked May 27, 2020 Martin K 6.6k points
1 vote
1 answer 30 views
30 views
Problem: I am getting an error message: windows error 2 occurred while loading the java VM I was just wondering if anyone had seen this kind of error before and if so, how to solve it. The very few answers I can find online relate to this issue. Somebody please step ahead and pull me up. Thanks
asked Mar 26, 2020 Gavin 15.3k points
0 votes
1 answer 14 views
14 views
Problem: I am trying to load Java Web App into the Eclipse (via the Import Maven Project) but I am facing below error which says: "Cannot change version of project facet Dynamic Web Module to 2.5". I am trying to do research on the above error and one thing I ... >  <installed facet="wst.jsdt.web" version="1.0"/> </faceted-project> Can someone help me in fixing above project facet related error.
asked Jul 7, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 56 views
56 views
Problem: Hi, i upgraded the wordpress to Wordpress 5..2.2 but it popups a notification that my server is running an older version. Can anyone suggest me the best solution.
asked Nov 2, 2020 prog_learner 2.5k points