• Register
0 votes
189 views

Problem :

When I wanted to install my module 'pymc' through the anaconda environments, it showed me the below error message:

UnsatisfiableError: The following specifications were found to be in conflict:

· blaze -> pyyaml -> python[version='>=2.7,<2.8.0a0'] -> vc=9

· blaze -> pyyaml -> yaml -> *[track_features=vc9]

· pymc Use "conda info " to see the dependencies for each package.

I am trying to use Python 2.7.14, and I also installed anaconda 1.6.9 on the Windows. I am very new to Python.

How can I resolve the above error?

6 5 3
7,540 points

1 Answer

0 votes

Solution :

Create your new conda environment for Python 2.7 with below command:

conda create -n my_pymc_env python=2.7

Activate it with below command:

conda activate my_pymc_env

Alternatively, for the older conda versions on a Windows:

activate my_pymc_env

on a Unix (including a Mac OS X):

source activate my_pymc_env

Once activated, install your packages with below command:

conda install pymc blaze

If you still get above message then install the Anaconda client with below command:

conda install anaconda-client

also look for your package with below command:

anaconda search mypackage

Search for the channel that has the right version for you and install with below command:

conda install -c channel_with_right_version mypackage

Hope this helps you in resolving your issues.

9 7 4
38,600 points

Related questions

1 vote
1 answer 72 views
72 views
Problem: Well, I have installed the seaborn package in my system by using conda install seaborn command. While I am trying to import the package in my script it shows an error ImportError: No module named seaborn Although the package has already installed on my system. I am ... you please shed some light on this, why I met with this error? I am looking for a solution to this problem. Thanks.
asked May 15 adamSw 11.3k points
0 votes
1 answer 3.8K views
3.8K views
Problem : gonzo  ~/a/packages  conda env list # conda environments: # ppo_latest /nohome/jaan/alecxe/anaconda3/envs/ppo_latest root * /nohome/jaan/alecxe/anaconda3 gonzo  ~/a/packages  conda activate ppo_latest gonzo  ~/a/packages  which python (ppo_latest) /nohome/jaan/ ... Then I want to check which python it is referring to it and it is not changing.., May I know why it is happening?
asked Nov 25, 2019 alecxe 7.5k points
0 votes
1 answer 18 views
18 views
Problem: I have basic knowledge of python, anaconda, plotly and msgpack. Now I am facing a problem while trying to install the plotly. I proceeded to upgrade my anaconda using a command line on a Debian 9 but unfortunately I received an error message saying: " ... .0 error message stopped my whole upgrading process of many of the packages. pip install msgpack does not really fix the above problem.
asked Aug 27 Raphael Pacheco 4.9k points
1 vote
1 answer 40 views
40 views
Problem : Currently I am learning anaconda and virtualenv. I want to start my virtual env using the virtualenv but I am facing below error: Already using interpreter /Users/pkilcrease/anaconda/bin/python3 Using base prefix '/Users/pkilcrease/anaconda' New python ... and virtualenv, but unable to fix the above error. Looking for experts advice for fixing above anaconda and virtualenv error.
asked May 6 stewart 4k points
1 vote
1 answer 119 views
119 views
Problem : I am very new to Python. Currently I am running the python script but I am constantly facing following error: “Intel MKL FATAL ERROR: Cannot load libmkl_avx2.so or libmkl_def.so.” Please note both of my files are present in a anaconda2/lib directory. I am very confused about above error so need Python experts help in fixing above error.
asked Apr 20 stewart 4k points