• Register
0 votes
221 views

Problem :

I am facing the below error

"Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled." 

Above error occurs while using a latest Gradle Plugin & a latest Android SDK.

7 5 2
3,870 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I launched the emulator and it was just fine but Android Studio was not able to start a project. It just sat there and waiting for something. Then I closed everything and restarted. I Tried running my project on the emulator again and I got the Error running app: Instant Run requires 'Tools | Android | Enable ADB integration' to be enabled.

I referred to some of many other answers to my error. The Android 2.3.3 settings dialog is the little different than a newest Android Studio.

To fix my problem I went to following path "File -> Settings -> Build, Execution, and then to Deployment -> InstantRun". At a top of a dialog is the check box to "Enable Instant Run to hot swap code/resource changes on deploy. Then I closed and restarted my Android Studio. And opened my project and clicked on run button. My emulator started and a compiled app launched. And the problem got resolved for me.

9 7 4
38,600 points

Related questions

0 votes
1 answer 1 view
1 view
Problem: After a successful import of an Eclipse-Android-Project into "Android Studio 1.4", I get the error "Please select Android SDK" when I click on the button to run the application in simulator, but I can't find any way of doing that.
asked 3 days ago ummesalma 25.2k points
0 votes
1 answer 70 views
70 views
Problem: adb.exe start-server' failed -- run manually if necessary.
asked Feb 24 Dan phillip 4.8k points
0 votes
1 answer 12 views
12 views
Problem: error: program type already present: android.support.v4.app.fragmenttransitioncompat21$1
asked Feb 20 Lucky Guy 1.5k points
0 votes
1 answer 11 views
11 views
Problem: could not find com.android.tools.build:aapt2:3.2.1-4818971.
asked Feb 16 charles mathews 5.5k points
0 votes
1 answer 119 views
119 views
Problem : I have updated my Android Studio to 3.0 but now facing the lot of issues.. So now stopped on the point with below issue: Could not resolve all files for configuration ':applib:_lintClassPath'. > Could not find com.android.tools.lint:lint-gradle:26.1.0-alpha01. ... project :applib I am currently using latest gradle version as: "gradle-4.2.1-all.zip". Does anyone know what my issue can be?
asked Dec 17, 2019 alecxe 7.5k points
0 votes
1 answer 6 views
6 views
Problem: how can solve it... how to create a music player app in android studio
asked Apr 1 Ifra 24.4k points
0 votes
1 answer 71 views
71 views
Problem : I am getting bellow error while I'm trying to setup an Android dev environment on Mac error:buildtools 24.0.2 requires java 1.8 or above. current jdk version is 1.7.
asked Oct 19, 2019 peterlaw 6.9k points
0 votes
1 answer 2 views
2 views
Problem: Can you suggest me how to run a project in android studio?
asked 2 days ago jamuna1 18.1k points
0 votes
1 answer 2 views
2 views
Problem: Anybody help me how to run a program in android studio?
asked 2 days ago jamuna1 18.1k points
0 votes
1 answer 6 views
6 views
Problem: Can I run the emulator without starting the Android Studio first? , I tried many times and failed, need help, please.
asked Apr 1 Jack20 3k points