• Register
0 votes
128 views

Problem :

I want to intstall the TensorFlow using pip.

I tried below command:

$ pip install tensorflow –user

But I got below error:

Collecting tensorflow
Could not find a version that satisfies the requirement tensorflow (from versions: )
No matching distribution found for tensorflow

How can I install the TensorFlow?

8 4 2
2,300 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I was facing the same issue on the Windows 10 with Python 3.6.X version then after checking properly I found that I had Python-32 bit installation on the 64 bit machine. As TensorFlow is only compatible with the 64bit installation of python and not with 32 bit of Python so I followed below procedure to fix it

I had download 64 bit installer manually to install the Python 64 bit. And after that added below paths to my PATH environment.

C:\Users\AppData\Local\Programs\Python\Python36
C:\Users\AppData\Local\Programs\Python\Python36\Scripts

Then I ran the gpupdate /Force on my command prompt. If the python command is not working for the 64 bit then restart the machine.

Then you should run python on the command prompt. And it must show 64 bit

C:\Users\YOURNAME>python
Python 3.6.3 (v3.6.3:2c5fed8, Oct  3 2017, 18:11:49) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.

Then I ran below command to install the tensorflow CPU version.

pip3 install --upgrade tensorflow
5 2 1
4,980 points

Related questions

0 votes
1 answer 20 views
20 views
I am struggling with Jetson TX2 board (aarch64). I need to install python wrapper for OpenCV. I can do: $ sudo apt-get install python-opencv But I cannot do: $ sudo pip install opencv-python Is this because there is no proper wheel file in http://www.lfd.uci.edu/~gohlke/pythonlibs/#opencv ? Is there a way to install opencv-python through pip?
asked Oct 25, 2020 psandprop 2.4k points
0 votes
1 answer 132 views
132 views
Problem : When I try to install PyGame with:pip install pygame i am getting below error python could not find a version that satisfies the requirement
asked Oct 22, 2019 peterlaw 6.9k points
1 vote
1 answer 94 views
94 views
Problem : I am very beginner to Tensorflow. I am trying to install the Tensorflow but I am unable to do so. I am following below procedure to install the tensorflow. >>> python -V Python 2.7.6 >>> pip -V pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2 ... /root/.pip/pip.log I am stuck with this error from past couple of days. Still unable to fix it. Please guide me in fixing this issue?
asked Mar 28, 2020 morrisBson 3.2k points
0 votes
2 answers 303 views
303 views
Problem : Currently I have installed Python version 3.5 and 3.6 and anaconda on my box. The following error comes up while trying to install tensorflow below are the steps https://www.tensorflow.org/install/install_windows using the anaconda (tensorflow) C:> pip install --ignore- ... . As I am very much new to Python, I am unable to resolve this problem. I am using the Windows 10 with 64bit.
asked Dec 11, 2019 alecxe 7.5k points
0 votes
1 answer 379 views
379 views
Problem: If I try to execute the command sess = tf.Session() in the Tensorflow 2.0 environment then I am facing below error message: Traceback (most recent call last): File "<stdin>", line 1, in <module> AttributeError: module 'tensorflow' has no attribute ' ... install numpy==1.16.2 Command Execution as below: Execute the command: import tensorflow as tf Execute the command: sess = tf.Session()
asked Jul 21, 2020 Raphael Pacheco 4.9k points
1 vote
1 answer 849 views
849 views
Problem : I am very beginner to Tensorflow. I am trying to use the Tensorflow from past couple of days. Now I am trying to install it and again reinstalling it again and again in my python2.7 and 3.4. But after doing so many installations I am still facing below ... for your reference: tf_in = tf.placeholder("float", [None, A]) # Features I need urgent help to fix above strange looking error.
asked Apr 29, 2020 stewart 4k points
0 votes
2 answers 572 views
572 views
Problem : In the MacOS Mojave terminal I am trying to install a python package with pip. At the end of it says as follows : You are using pip version 10.0.1, however version 18.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Here ... to do.Also I just realized that it says Python 2.7 in the error message but I have python 3 and want to use only python 3.
asked Dec 10, 2019 alecxe 7.5k points
0 votes
1 answer 1.6K views
1.6K views
Problem : I am very new to Quartz. So whenever I try to install Quartz on my system using pip install Quartz, I face the following error. Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 1, in <module> ... [Errno 2] No such file or directory: 'requirements.txt' I am using Mac OSX with Anaconda. Does anyone have any clue on this issue?
asked Nov 27, 2019 alecxe 7.5k points
0 votes
1 answer 647 views
647 views
Problem : I want to learn the Machine Learning but I am unabe to resolve below error. My Specs : · Mac High Sierra 10.13.2 · Python3.4.5 · Numpy1.13.3 Used below Command: $ python3 -c "import jupyter, matplotlib, numpy, pandas, scipy, sklearn" I am ... to import pandas from the source directory, you may need to run 'python setup.py build_ext --inplace --force' to build the C extensions first.
asked Dec 4, 2019 alecxe 7.5k points