• Register
0 votes
53 views

Problem :

I am new to python. I have tried to install below softwares:

Python 2.5.4, Numpy 1.5.0 win32, Matplotlib 1.0.0 win32, pywin32 218.

After doing so much of hard work I am still unable to plot the graphs in Python.

I am facing below error message:

import pylab
   File "C:\Python25\lib\site-packages\pylab.py", line 1, in <module>
      from matplotlib.pylab import *
   File "C:\Python25\lib\site-packages\matplotlib\pylab.py", line 216, in <module>
      from matplotlib import mpl  # pulls in most modules
   File "C:\Python25\lib\site-packages\matplotlib\mpl.py", line 1, in <module>
      from matplotlib import artist
   File "C:\Python25\lib\site-packages\matplotlib\artist.py", line 6, in <module>
      from transforms import Bbox, IdentityTransform, TransformedBbox, TransformedPath
   File "C:\Python25\lib\site-packages\matplotlib\transforms.py", line 34, in <module>
      from matplotlib._path import affine_transform
ImportError: DLL load failed: The specified module could not be found.

Can somebody help me in fixing this error?

8 4 2
2,300 points

Please log in or register to answer this question.

1 Answer

0 votes

Solution :

I had faced such issues in the recent past. I did lot of research on it and found solution on it. Please try to follow below tips to fix the error.

I started with downloading the msvcp71.dll and msvcr71.dll from the internet.

After downloading I saved them to my C:\Windows\System32 folder.

And if you are using 64-bit operating system then you need to save them to the C:\Windows\SysWOW64 folder also. Now you can try to run your code file in your Python and it will surprise you by loading your graph within few seconds.

I hope this solution will fix your error

5 2 1
4,980 points

Related questions

0 votes
1 answer 12 views
12 views
Problem: I am starting my work with the images in Python and I am trying to start using PIL (Pillow). To install the PIL I ran the following command: pip install Pillow. While installing the PIL was not previously installed. I also tried to uninstall it and then reinstall it ... my PIL folder. Why is this showing me the error if the needed DLL is already there? How can a beginner like me fix it?
asked Aug 27, 2020 Raphael Pacheco 4.9k points
1 vote
1 answer 41 views
41 views
Problem: I am working on a django project but after working for several days when I opened atom today and try to write program it shows: (Uncaught Error: The specified module could not be found. \?\C:\Users\ASUS\AppData\Local\atom\app-1.45.0\resources\app.asar.unpacked\ ... .node ELECTRON_ASAR.js:160) I can not write any code or remove any word for this error. What should I do to fix this error?
asked Jun 7, 2020 samhaz 5k points
0 votes
1 answer 1.9K views
1.9K views
Problem : The import matplotlib.pyplot as plt is is giving me the error with python2.7, anaconda3. The error shown is as below: ImportError: libGL.so.1: cannot open shared object file: No such file or directory The Detailed Error report is as below : Traceback ... <module> from PyQt5 import QtCore, QtGui, QtWidgets ImportError: libGL.so.1: cannot open shared object file: No such file or directory
asked Dec 18, 2019 alecxe 7.5k points
0 votes
1 answer 828 views
828 views
Problem: I am having the conda environment where Numpy, SciPy and TensorFlow are installed. Conda is using the Intel(R) MKL Optimizations. The Anaconda has packaged the MKL-powered binary versions of some of the most popular numerical/scientific Python ... cause crashes or silently produce incorrect results. For more information, please see http://www.intel.com/software/products/support/.
asked Nov 25, 2019 alecxe 7.5k points
0 votes
1 answer 431 views
431 views
Problem : Recently I have installed the tensorflow with a gpu support also with cuda toolkit v9.0 and cuDNNv7.1 and python 3.6 in the conda enviroment. When I tried below command it is giving me following error import tensorflow as tf Traceback (most ... _bootstrap._gcd_import(name[level:], package, level) ImportError: DLL load failed: A dynamic link library (DLL) initialization routine failed.
asked Feb 18, 2020 mphil 2.3k points
0 votes
1 answer 1.5K views
1.5K views
Problem : I am finding solution on following issue deprecationwarning: elementwise == comparison failed; this will raise an error in the future.
asked Nov 15, 2019 peterlaw 6.9k points
1 vote
1 answer 34 views
34 views
Problem: Yesterday I uninstalled Anaconda and shut down my computer. Right now, I&rsquo;ve freshly installed the Anaconda again on my laptop to run a project. Suddenly, I am facing an ImportError to run a python project. ImportError: Missing required dependencies ['numpy'] ... but it produces the same error again and again. Do you have any clear idea about this problem and how to solve it?
asked Jun 20, 2020 adamSw 11.3k points
0 votes
1 answer 11 views
11 views
Problem: How can I put the text in the upper left (or upper right) corner of the matplotlib plot, such as where the top left legend will be, or on top of the plot but in the upper left corner? For example. if it is plt.scatter (), then something that is ... in the upper right corner. When positioning the legend type, it must not overlap with any points on the scatter plot in any case. Thank you!
asked Dec 30, 2020 sasha 5.3k points
0 votes
1 answer 1.1K views
1.1K views
Problem: I have recently installed opencv with all the dependencies. After the successful installation I have tried to import matplotlib for the very simple example. I have started facing below error when I only tried to install matplotlib via the pip with pip install ... linux-gnu.so' Consider using the `--user` option or check the permissions. How can I install matplotlib without any error?
asked Aug 26, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 357 views
357 views
Problem : I have just upgraded to a latest stable release of matplotlib (1.5.1) and everytime I import the matplotlib I get below message: /usr/local/lib/python2.7/dist-packages/matplotlib/font_manager.py:273: UserWarning: Matplotlib is building the font cache using fc ... always stalls for the few seconds. Is this a expected behavior? Was it a same also before, but just without a printed message?
asked Jan 24, 2020 jwilliam 3.9k points