• Register
1 vote
27 views

Problem:

I've installed Python 3.4 and Python 3.6 on my local machine successfully but am unable to install packages with pip3.

 

pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Collecting <package>
  Could not fetch URL https://pypi.python.org/simple/<package>/: There was a problem confirming the ssl certificate: Can't connect to HTTPS URL because the SSL module is not available. - skipping
  Could not find a version that satisfies the requirement <package> (from versions: )
No matching distribution found for <package>

 

12 7 7
15,250 points

Please log in or register to answer this question.

1 Answer

1 vote
 
Best answer

 

Solution:

I am assuming that you have installed python in your machine already. To install pip3 follow the steps below carefully:

Open your terminal and follow these commands sequentially.

sudo apt install python3-pip
pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6)

Congratulation. You’ve installed pip3  on your machine.

 

In case you are using a Windows-based OS:

 1) you can download python again on the official website;

2) Navigate to the directory where "Python 3.7 (64-bit).lnk"is located

3) import ssl and exit()

4) type in cmd, "Python 3.7 (64-bit).lnk" -m pip install tensorflow for instance.

Here, you're all set.

13 9 6
94,240 points

Related questions

0 votes
1 answer 68 views
68 views
Problem: I've install Python 3.4 and Python 3.6 on my local machine successfully, but am unable to install packages with pip3. When I execute pip3 install <package>, I get the following SSL related error: pip is configured with locations that require TLS/SSL, ... matching distribution found for <package> How can I fix my Python3.x install so that I can install packages with pip install <package>?
asked Jan 9 Mashhoodch 13k points
1 vote
1 answer 419 views
419 views
Problem : I am beginner to Python. Currently if I try to use the request module to have the urls text then I often face below Error: Traceback (most recent call last):  File "/usr/local/lib/python3.6/site-packages/requests-2.18.1-py3.5.egg/requests/adapters.py" ... to get the url's text to parse it. Please find below my line of code for your reference: mytext = requests.get(detail_path).mytext
asked May 2, 2020 stewart 4k points
0 votes
1 answer 2 views
2 views
Problem: How can I deal with this problem: error: the python ssl extension was not compiled. missing the openssl lib?
asked Apr 1 rakib1 51.5k points
1 vote
1 answer 4 views
4 views
Problem: I am unable to find out the solution, Please solve it : python 'module' object is not callable
asked Mar 31 MUHAMMAD MUNEEB 83k points
1 vote
1 answer 4 views
4 views
Problem: I am unable to find out the solution, Please solve it : python typeerror: 'module' object is not callable
asked Mar 19 MUHAMMAD MUNEEB 83k points
1 vote
1 answer 76 views
76 views
Problem: I have a python project located at C:\Users\ASUS\Documents\OPO\aoi.py But when I try to run this project: C:\Users\ASUS\Documents\OPO\aoi.py, line 55, in __init__ self.serv = socket(AF_INET,SOCK_STREAM) TypeError: 'module' object is not callable Why am I getting this type of error message. Can anyone explain me this thing.
asked Apr 4, 2020 LizzyM 6.1k points
0 votes
1 answer 189 views
189 views
Problem : With my two classes I want to connect to the MySQL database. But, I always get below error: Wed Dec 04 10:46:52 CET 2019 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ ... public void close(){ if(conn != null){ try { conn.close(); } catch (SQLException e) { e.printStackTrace(); } } } }
asked Dec 4, 2019 alecxe 7.5k points
0 votes
1 answer 2 views
2 views
Problem: I have faced this problem for a very long time.Please help me out of this:this video contains content from columbia. it is not available in your country.
asked 5 days ago ashik 12.9k points
0 votes
1 answer 9 views
9 views
Problem: The total space of my application is 10MB, and after installation it will take less than 20MB. On Galaxy Note I, while updating my app, it says "Not Enough Storage Space Available", where there is 214MB of free space in device memory (internal) ... /mnt/sdcard: 1928992K total, 1014496K used, 914496K available (block size 32768) /mnt/secure/asec: Permission denied Hope someone could help.
asked Mar 17 sasha 16.2k points
0 votes
1 answer 3 views
3 views
Problem : Anyone is here to solve my problem ?-google play store this item is not available in your country?
asked Mar 15 Samiur1 38.4k points