• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
8 views

Problem:

.Net framework 2.0, 3.5 and 4 are installed and I am using SQL 2008. I am getting following error:

an asp.net setting has been detected that does not apply in integrated managed pipeline mode.

Need suggestions why is this happening?

by (330 points)  

1 Answer

0 votes

Possible Cause:

The reason for this may be adding new library to old projects.

This also happens if you try to run app built for IIS6 on version IIS7 etc.

Solution1:

Use following configuration with validateIntegratedModeConfiguration set to false

<configuration>

    <system.webServer>

        <validation validateIntegratedModeConfiguration="false"/>

    </system.webServer>

</configuration>

Solution2:

Try to change Managed pipeline mode to Classic.

an asp.net setting has been detected that does not apply in integrated managed pipeline mode.png

by (1.4k points)  
...