• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
11 views

Problem:

I am facing the below compiler error while trying to run the code using eclipse IDE

java compiler level does not match the version of the installed java project facet

by (300 points)  
edited by

1 Answer

0 votes

Possible Cause:

It seems your Java Version in your eclipse Project Facets is incorrect.

Solution :

Please follow below steps to correct the java version :

1. Please Right click on the "project" in your Eclipse IDE -> Properties -> Project Facets

2. Select the correct Java version you are using.

3. Apply and close

Conlusion:

Please always make sure that Java Version in your eclipse Project Facets is always correct.

by (33.3k points)  
edited by
...