• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
11 views

Problem :

I am trying to execute bootstrap jquery code but getting below error
uncaught error: bootstrap's javascript requires jquery at bootstrap.min.js:6

by (6.9k points)  

1 Answer

0 votes

Solution : 

To solve the issue you must put jQuery above the Bootstrap JS as shown bellow.

    <!-- jquery -->
    <script src="//code.jquery.com/jquery-1.12.0.min.js"></script>
    <script src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
    <!-- [/] jquery -->

    <!-- bootstrap -->
    <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.6/js/bootstrap.min.js" integrity="sha384-0mSbJDEHialfmuBBQP6A4Qrprq5OVfW37PRR3j5ELqxss1yVqOtnepnHVP9aJ7xS" crossorigin="anonymous"></script>
    <!-- [/] bootstrap -->

Further Readings:

https://github.com/aurelia/cli/issues/478

by (21.9k points)  
edited by
...