• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
11 views

Problem :

I am getting this error when I include an opensource library that I had to compile from source.
java lang unsupportedclassversionerror bad version number in class file
by (6.9k points)  

1 Answer

0 votes

Solution :

The reason behind you are getting this message is one of your projects is compiling 1.6 classes. It wont matter if you only have a 1.5 JRE on the system, because Eclipse has its own compiler and only needs a 1.5 JRE to compile 1.6 classes.

Follow bellow steps to resolve the issue:

Check the Project Properties>Java Compiler section

enter image description here

Further Readings:

https://www.eclipse.org/forums/index.php/t/1067175/

by (21.9k points)  
edited by
...