• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
10 views

Problem :

I am getting bellow error when running a JUnit test using IntelliJ IDEA

error java javactask source release 1.7 requires target release 1.7

by (6.9k points)  

1 Answer

0 votes

Solution :

There are two ways to resolve this issue:

  1. Set settings (File -> Settings -> Build, Execution, Deployment -> Java Compiler): enter image description here
  2. Add bellow build section to your pom.xml: enter image description here

Further Readings:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/206206319-Upgraded-to-12-1-4-and-now-java-javacTask-source-release-1-7-requires-target-release-1-7-

by (20.3k points)  
edited by
...