• Register
Welcome to Kodlogs, programming questions and answer website.
0 votes
8 views

Problem :

When I wanted to install my module 'pymc' through the anaconda environments, it showed me the below error message:

UnsatisfiableError: The following specifications were found to be in conflict:

· blaze -> pyyaml -> python[version='>=2.7,<2.8.0a0'] -> vc=9

· blaze -> pyyaml -> yaml -> *[track_features=vc9]

· pymc Use "conda info " to see the dependencies for each package.

I am trying to use Python 2.7.14, and I also installed anaconda 1.6.9 on the Windows. I am very new to Python.

How can I resolve the above error?

by (7.5k points)  

1 Answer

0 votes

Solution :

Create your new conda environment for Python 2.7 with below command:

conda create -n my_pymc_env python=2.7

Activate it with below command:

conda activate my_pymc_env

Alternatively, for the older conda versions on a Windows:

activate my_pymc_env

on a Unix (including a Mac OS X):

source activate my_pymc_env

Once activated, install your packages with below command:

conda install pymc blaze

If you still get above message then install the Anaconda client with below command:

conda install anaconda-client

also look for your package with below command:

anaconda search mypackage

Search for the channel that has the right version for you and install with below command:

conda install -c channel_with_right_version mypackage

Hope this helps you in resolving your issues.

by (33.3k points)  
...