• Register

Recent questions tagged macos

0 votes
1 answer 24 views
Problem: I am learning ruby and I have updated XCode on my Mac and since then when I run Docker using docker-sync-stack startI get the following error: mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/ ... :, brew install rbenv ruby-buildbut that doesn't change anything. Does anyone have idea how I should fix this? I will be thankful!
asked Dec 2, 2020 sasha 5.3k points
0 votes
2 answers 69 views
On trying to run the command below there show some errors. $ gulp build In my terminal and I get this assertion error. I've uninstalled node and NPM and reinstalled again using brew - How do I completely uninstall Node.js, and reinstall from beginning (Mac OS X) with these steps. My ... /**/*'], [panini.refresh]); }); // Erases the dist folder gulp.task('reset', function() { rimraf('bulma/*');
asked Oct 30, 2020 psandprop 2.4k points
2 votes
1 answer 421 views
Problem : I am very new to Mongodb, I am facing below error if I try to run the Mongodb. I had installed it with the help of Homebrew. Stewarts-MacBook-Pro:~ stewart$ mongod 2020-05-05T15:31:15.911+0700 I CONTROL  [initandlisten] MongoDB starting : pid ... +0700 I CONTROL  [initandlisten] shutting down with code:48 Stewarts -MacBook-Pro:~ stewart $ Kindly help me in resolving above Mongodb error.
asked May 6, 2020 stewart 4k points
1 vote
1 answer 25 views
Problem : Recently I have started learning Homebrew. Now if I try to run Homebrews brew doctor command on my Mac OS X 10.9.2 I have started receiving the below listed warning message: Warning: Python is installed at /Library/Frameworks/Python.framework Homebrew only ... /usr/local/bin/python. But still if I rerun the brew doctor command I am still facing the same warning message listed above.
asked Apr 4, 2020 morrisBson 3.2k points
1 vote
2 answers 160 views
Problem : I am beginner to the monaca. Currently I am trying to install the monaca with the use of below command. npm install -g monaca But I am facing below errors after executing above command: npm WARN checkPermissions Missing write access to /usr/local/lib/ ... /lib/node_modules' } I am struggling with above error from past couple of days. Can somebody help me in fixing above monaca error?
asked Mar 27, 2020 morrisBson 3.2k points
0 votes
1 answer 353 views
Problem : Currently I am learning Homebrew (Mojave). Recently I tried to install the node using Homebrew (Mojave) but after sometime my Php stopped working and now if I try to run the command php -v I face below error: php -v dyld: Library not loaded: /usr/local ... from: /usr/local/bin/php Reason: image not found I have also tried to uninstall my both node and icu4c but my problem still persists
asked Feb 20, 2020 mphil 2.3k points
0 votes
1 answer 566 views
Problem : Recently I installed the python3 and also jupyter notebook using the pip3 on MacOs 10.9. But when I want to run my widget it gives me error that there is no javascript widget. I have the python3 and R kernels installed in my Jupyter-notebook. ... that in my mac I have the jupyter-nbextension command but the command: jupyter-nbextension enable --py widgetsnbextension Does not work for me.
asked Jan 27, 2020 jwilliam 3.9k points
0 votes
1 answer 189 views
Problem : I am trying to install the gem using gem install mygem or update a RubyGems using gem update --system, and it fails with below error: ERROR:  While executing gem ... (Gem::FilePermissionError) You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory. Does anyone have the idea how to fix this error?
asked Jan 22, 2020 jwilliam 3.9k points
0 votes
1 answer 520 views
Problem : I want to run the specs, you will need to install RSpec. First, run the gem install bundler in a root directory of the project. Then, run the bundle install. To run the single spec file, run the command like below: bundle exec rspec spec/00_hello_spec.rb. To ... ruby, and I want to bundle install inside of the atom? Could anyone tell me how to use the atom or run anything in the atom?
asked Jan 22, 2020 jwilliam 3.9k points
1 vote
2 answers 653 views
Problem : I am using the VirtualBox with OS X as host and CentOS on a guest VM. In OS X I created the folder myfolder, added it as a shared folder to a VM, turned on a VM, in CentOS created folder as /home/user/myfolder and typing as below : sudo ... /user/myfolder But have below output: /sbin/mount.vboxsf: mounting failed with the error: No such device What am I doing wrong in above scenario?
asked Jan 22, 2020 jwilliam 3.9k points
0 votes
2 answers 56 views
Problem : Below are the steps I went through: Generate the certificate request: Upload to the Apple Dev Portal, download the certificate. Select it in the Xamarin Project options: Tried to build, when getting to a codesigning it asks permission (is a name being "" correct?) ... - should I try to set these manually? Where can I find all the keys of a signing profile / certificate to do so?
asked Jan 20, 2020 jwilliam 3.9k points
0 votes
1 answer 1.2K views
Problem : When attempting to start the servers, Apache fails to start, and MAMP claims that my port ([::]:8888) is already in the use. I have tried virtually every way I know of determining what the process is using that port (as well as many of other solutions ... what(if anything) is really using my port, or somehow convince the MAMP that my port is not actually in use. Any suggestions on this?
asked Jan 17, 2020 jwilliam 3.9k points
0 votes
1 answer 1.6K views
Problem : I want to view my php files locally on my mac. I am trying to run Yosemite on my mac. I have the MAMP installed on my mac. When I press start my MySQL server starts as usual but my Apache doesn't start at all. An error message is shown ... also tried reinstalling the OSX and that worked but until I shut down my mac the problem reoccurs. Can anyone help with the solution on above error?
asked Dec 19, 2019 alecxe 7.5k points
0 votes
2 answers 580 views
Problem : In the MacOS Mojave terminal I am trying to install a python package with pip. At the end of it says as follows : You are using pip version 10.0.1, however version 18.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Here ... to do.Also I just realized that it says Python 2.7 in the error message but I have python 3 and want to use only python 3.
asked Dec 10, 2019 alecxe 7.5k points
0 votes
2 answers 72 views
Problem : I am very much new to the whole Mac experience. I have recently installed MySQL on Mac and it is asking me to reset the password after install. It is not allowing me to do anything else. Now I have already reset the password the usual way as below: update ... I need to change the password but in some different way that is not known to me. Can someone here has any solution on my problem?
asked Dec 4, 2019 alecxe 7.5k points
0 votes
2 answers 140 views
Problem : I am using Mac. I want to run my docker code. Following is my command: docker run -d -p 80:80 --name webserver nginx However I am facing below error: docker: Error response from daemon: driver failed programming external connectivity on endpoint webserver ( ... userland proxy: Bind for 0.0.0.0:80: unexpected error (Failure EADDRINUSE). Please let me know if any solution on my error.
asked Dec 3, 2019 alecxe 7.5k points
0 votes
1 answer 38 views
Problem : I want to run the NVCC to compile my CUDA program on my Mac. But when I try to run the NVCC, I am facing below error message: "nvcc fatal : The version ('70300') of the host compiler ('Apple clang') is not supported". I tried updating the XCode version to 7.3, and the Mac version to 10.11.4. But I am facing the same error. How can I revert my Apple Clang Version?
asked Nov 30, 2019 alecxe 7.5k points