• Register

Recent questions tagged pip

0 votes
1 answer 2 views
Problem : zipimport.zipimporterror: can't decompress data; zlib not available
asked 23 hours ago Shovo210 2.5k points
0 votes
1 answer 3 views
Problem: could not find a version that satisfies the requirement pip.
asked Feb 18 Ethan ross 1.8k points
0 votes
1 answer 5 views
Problem: I'm new to Python and have been trying to install some packages with pip. But pip install unroll gives me Command "python setup.py egg_info" failed with error code 1 in C:\Users\MARKAN~1\AppData\Local\Temp\pip-build-wa7uco0k\unroll\ How can I solve this?
asked Feb 18 Mashhoodch 9.1k points
0 votes
1 answer 10 views
Problem: from pip import main importerror: cannot import name 'main'
asked Feb 17 charles mathews 3.8k points
0 votes
1 answer 54 views
Problem: I am trying to install python package rpy2 with pip install on Ubuntu 16.04: pip install rpy2==2.2.7 but get error message (see full output below): Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-EuOI6K/unroll/
asked Jan 10 Mashhoodch 9.1k points
0 votes
1 answer 39 views
Problem: I am trying to install virtualenv on Ubuntu. First it said command 'pip' not found, so I typed sudo apt install python-pip then it said E: Unable to locate package python-pip I tried to reset WSL, download using cmd but it doesn't work with Ubuntu. I don' ... though I have downloaded python3, virtualenv, and pip using cmd. It doesn't work with Ubuntu 18.04. It also fails on Ubuntu 14.04.
asked Jan 8 Mashhoodch 9.1k points
0 votes
2 answers 15 views
Problem: I run sudo pip install git-review, and get the following messages: Downloading/unpacking git-review Cannot fetch index base URL http://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement git-review No distributions at all found for git-review Storing complete log in /home/sai/.pip/pip.log Does anyone has any idea about this?
asked Jan 8 Mashhoodch 9.1k points
0 votes
1 answer 49 views
I am struggling with Jetson TX2 board (aarch64). I need to install python wrapper for OpenCV. I can do: $ sudo apt-get install python-opencv But I cannot do: $ sudo pip install opencv-python Is this because there is no proper wheel file in http://www.lfd.uci.edu/~gohlke/pythonlibs/#opencv ? Is there a way to install opencv-python through pip?
asked Oct 25, 2020 psandprop 2.4k points
0 votes
1 answer 1.7K views
Problem: I have recently installed opencv with all the dependencies. After the successful installation I have tried to import matplotlib for the very simple example. I have started facing below error when I only tried to install matplotlib via the pip with pip install ... linux-gnu.so' Consider using the `--user` option or check the permissions. How can I install matplotlib without any error?
asked Aug 26, 2020 Raphael Pacheco 4.9k points
0 votes
1 answer 30 views
Problem: I am having an error of ImportError while trying to import _weakref. The error message looks like this: ImportError: cannot import name _remove_dead_weakref I understand something sneaky happened there in my codes but couldn’t identify the point of error. ... ;ll have a feasible solution from this forum. I am looking forward to reading your solutions. Thanks for your concern.
asked Jun 21, 2020 adamSw 11.3k points
1 vote
1 answer 35 views
Problem : I have recently started working on Continuous Integration. Currently I have the Continuous Integration which works properly with Gitlab. If I try to it deploy then it installs everything which is present in the requirements.txt file with the help of pip. ... .txt"         - "python manage.py migrate --noinput" Please help me in fixing the above error related to Continuous Integration.
asked May 13, 2020 Martin K 6.6k points
1 vote
1 answer 134 views
Problem: I tried to install mysql in my system by running the command: pip install mysql-python But it shows: C:\Users\ASUS>pip install mysql-python Collecting mysql-python Downloading https://files.pythonhosted.org/packages/a5/e9/51b544da85a36a68debe7a7091f068d802fc515a3a202652828c73453cad/MySQL ... --user --prefix= Check the logs for full command output. What should I do now to fix this problem.
asked May 12, 2020 samhaz 5k points
2 votes
1 answer 3.1K views
Problem: When I try to run the below command on my command prompt: python get-pip.py It shows the following message: C:\Users\ASUS>python get-pip.py python: can't open file 'get-pip.py': [Errno 2] No such file or directory How can I have pip installed in my system. Then why am I getting this error message and why I can not open this file. Thanks in advance.
asked May 6, 2020 samhaz 5k points
1 vote
1 answer 99 views
Problem: Hello Guys, I’ve just installed fresh Ubuntu 18.04 LTS on my machine as my primary OS. Previously, I was using Windows 10 for my daily usages. After shifting to Linux I am installing all my necessary programs to it. I was looking for a ... : Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python-pip Any solution?
asked Apr 27, 2020 Gavin 15.3k points
2 votes
1 answer 38 views
Problem: I am new in programming language. I was trying to setup and then upgrade gcloud using python. I used the command: pip install --upgrade gcloud After that it shows: Collecting gcloud Downloading gcloud-0.18.3.tar.gz (454kB) 100% | ... code 1 in C:\Users\bid\AppData\Local\Temp\pip-build-ppc44asr\googleapis-common-protos\ Whats is happening here can anyone help?
asked Mar 24, 2020 LizzyM 6.1k points
0 votes
3 answers 237 views
I am new in python programming. I am tryin gto iinstall some packages with pip commands. I tried to install a package called unroll by using the command: pip[ install unroll but it gives me some error like : "python setup.py egg_info" failed with error code 1 How can I solve this problem? How can I check my pip version? How can I upgrade my pip version?
asked Mar 9, 2020 LizzyM 6.1k points
0 votes
1 answer 739 views
Problem : I am new to HTMLParser my terminal showing me below error :- from django.utils.html import format_html, format_html_join, escape File "/usr/local/lib/python3.5/dist-packages/django/utils/html.py", line 16, in from .html_parser import HTMLParser, HTMLParseError ... I replace the HTMLParser with some other similar? Or should I try to downgrade the python ? Can someone help on this issue?
asked Mar 2, 2020 mphil 2.3k points
0 votes
1 answer 141 views
Problem : I want to intstall the TensorFlow using pip. I tried below command: $ pip install tensorflow –user But I got below error: Collecting tensorflow Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow How can I install the TensorFlow?
asked Feb 19, 2020 mphil 2.3k points
0 votes
1 answer 114 views
Problem : I am usually installing the python packages through the pip. For my Google App Engine, I need to install the packages to another target directory. I have already tried below command : pip install -I flask-restful --target ./lib But it is failing with below error: “Must supply either home or prefix/exec-prefix -- not both” How can I get my App to work?
asked Jan 6, 2020 alecxe 7.5k points
0 votes
1 answer 2.7K views
Problem : Following is my issue: I tried to install mysqlclient like below : C:\Users\alecxe>pip install mysqlclient Collecting mysqlclient Using cached https://files.pythonhosted.org/packages/ec/fd/83329b9d3e14f7344d1 cb31f128e6dbba70c5975c9e57896815dbb1988ad/mysqlclient-1.3.13.tar.gz Installed ... beginner to this and would be very happy if any input as to how to go about fixing above error.
asked Dec 27, 2019 alecxe 7.5k points